<!DOCTYPE html>
<html lang="en">
    <head>
        <meta charset="utf-8" />        
        <title>Raspberry Pi system can detect viruses on other devices without use of software</title>
        <meta http-equiv="Keywords" content="hi-tech news, hitech, innovation , inventions , computer news, information technology" name="Keywords">
        <meta http-equiv="Description" content="A team of researchers at the Institute of Computer Science and Random Systems has built a non-software-based virus detection system using a Raspberry Pi, an H-field probe and an oscilloscope to detect electromagnetic wave ..." name="Description">
        <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
        <meta name="ROBOTS" content="INDEX,FOLLOW" />
        <meta name="viewport" content="width=device-width, initial-scale=1" />            
        <link rel="canonical" href="https://techxplore.com/news/2022-01-raspberry-pi-viruses-devices-software.html" />
        <link rel="top" title="" href="/" />
        <link rel="manifest" href="/manifest.json">
        <link rel="search" href="https://techxplore.com/search/" />  
        
    <link rel="amphtml" href="https://techxplore.com/news/2022-01-raspberry-pi-viruses-devices-software.amp">
    <link rel="alternate" title="All news stories" href="https://techxplore.com/rss-feed/" type="application/rss+xml" />
    <link rel="alternate" title="Spotlight news only" href="https://techxplore.com/rss-feed/breaking/" type="application/rss+xml" />

        <link rel="shortcut icon" href="https://techxplore.com/favicon.ico" type="image/x-icon" />
        <meta name="apple-itunes-app" content="app-id=1154953172">
        <meta name="google-play-app" content="com.PhysOrg.TechXplore">
        <meta property="twitter:account_id" content="2471009922" />
        <meta property="fb:app_id" content="412372938960445" />
        <meta property="fb:pages" content="1410647052543567" />
        <meta property="og:title" content="Raspberry Pi system can detect viruses on other devices without use of software" />
        <meta property="og:description" content="A team of researchers at the Institute of Computer Science and Random Systems has built a non-software-based virus detection system using a Raspberry Pi, an H-field probe and an oscilloscope to detect electromagnetic wave signatures of multiple types of viruses. The team presented its system and test results at last month's ACM Machinery's Annual Computer Security Applications Conference and published a paper describing their system on ACM's Research Article page." />
        <meta property="og:url" content="https://techxplore.com/news/2022-01-raspberry-pi-viruses-devices-software.html" />
        <meta property="og:image" content="https://scx2.b-cdn.net/gfx/news/hires/2022/raspberry-pi.jpg" />
        <meta property="og:type" content="article" />        
        <meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:url" content="https://techxplore.com/news/2022-01-raspberry-pi-viruses-devices-software.html" />
	<meta name="twitter:title" content="Raspberry Pi system can detect viruses on other devices without use of software" />
	<meta name="twitter:description" content="A team of researchers at the Institute of Computer Science and Random Systems has built a non-software-based virus detection system using a Raspberry Pi, an H-field probe and an oscilloscope to detect ..." />
                    <meta name="twitter:image" content="https://scx2.b-cdn.net/gfx/news/2022/raspberry-pi.jpg" />
            <meta name="thumbnail" content="https://scx1.b-cdn.net/csz/news/tmb/2022/raspberry-pi.jpg" />
        
        
        <link rel="stylesheet" href="https://techx.b-cdn.net/tmpl/v2/css/libs.3377692561.css">
        <link rel="stylesheet" href="https://techx.b-cdn.net/tmpl/v2/css/style.3734226658.css">
        <link rel="preload" as="image" href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg">
    
                
        
   <!-- preload --->
      <link rel="preload" as="image" href="https://scx1.b-cdn.net/csz/news/800a/2022/raspberry-pi.jpg">
    	<script type='text/javascript'>
	    var googletag = googletag || {};
	    googletag.cmd = googletag.cmd || [];
	    (function() {
	      var gads = document.createElement('script');
	      gads.async = true;
	      gads.type = 'text/javascript';
	      var useSSL = 'https:' == document.location.protocol;
	      gads.src = (useSSL ? 'https:' : 'http:') +
		'//www.googletagservices.com/tag/js/gpt.js';
	      var node = document.getElementsByTagName('script')[0];
	      node.parentNode.insertBefore(gads, node);
	    })();
	</script>
      
	<script type='text/javascript'>
	    googletag.cmd.push(function() {
	      	      googletag.defineSlot('/4988204/TechX_Story_InText_Box', [[300, 250], [336, 280]], 'div-gpt-ad-1453799284784-2').addService(googletag.pubads());
		  googletag.defineSlot('/4988204/TechX_Story_Right_Box', [[336, 280], [300, 250], [300, 600]], 'div-gpt-ad-1453799284784-3').defineSizeMapping([ [[1200,0], [[336, 280], [300, 250], [300,600]]], [[0,0],[]] ]).addService(googletag.pubads());
	      googletag.defineSlot('/4988204/TechX_Story_Below_Rectangle', [[336, 280], [500, 250], [800,250]], 'div-gpt-ad-1453799284784-1').defineSizeMapping([ [[1200,0], [[336, 280], [500, 250], [800,250]]], [[0,0], [[336, 280], [500, 250]]] ]).addService(googletag.pubads());
	      googletag.pubads().setTargeting("r",["viewStory"]).setTargeting("categ", ["security"]);
	      googletag.pubads().enableSingleRequest();
	      googletag.pubads().collapseEmptyDivs();
	      googletag.enableServices();
	    });
	</script>
	      <script type="application/ld+json">
	    {
	      "@context": "http://schema.org",
	      "@type": "NewsArticle",
	      "mainEntityOfPage":{
            "@type":"WebPage",
            "@id":"https://techxplore.com/news/2022-01-raspberry-pi-viruses-devices-software.html"
              },
        "headline": "Raspberry Pi system can detect viruses on other devices without use of software",
                "image": {
            "@type": "ImageObject",
            "url": "https://scx2.b-cdn.net/gfx/news/hires/2022/raspberry-pi.jpg",
            "width": 2880,
            "height": 1621
              },
        "datePublished": "2022-01-11T09:40:03-05:00",
        "dateModified": "2022-01-11T09:40:03-05:00",
        "author": {
            "@type": "Person",
            "name": "Bob Yirka"
           },
        "publisher": {
            "@type": "Organization",
            "name": "Tech Xplore",
            "logo": {
              "@type": "ImageObject",
              "url": "https://techx.b-cdn.net/pic/techx.amp.png",
              "width": 280,
              "height": 60
            }
	      },
	      "description": "A team of researchers at the Institute of Computer Science and Random Systems has built a non-software-based virus detection system using a Raspberry Pi, an H-field probe and an oscilloscope to detect electromagnetic wave signatures of multiple types of viruses. The team presented its system and test results at last month's ACM Machinery's Annual Computer Security Applications Conference and published a paper describing their system on ACM's Research Article page.",
        "speakable": {
          "@type":"SpeakableSpecification",
          "xpath":["/html/head/title", "/html/head/meta[@name='Description']/@content"]
        }
	    }
      </script>
      <script type="application/ld+json">
      {
        "@context": "https://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [{
            "@type": "ListItem",
            "position": 1,
            "name": "Home",
            "item": "https://techxplore.com/"
          },{
            "@type": "ListItem",
            "position": 2,
            "name": "Security",
            "item": "https://techxplore.com/security-news/"
          }]
      }</script>
      
        
        <script type="text/javascript">
                window.google_analytics_uacct = "UA-73855-17";
                </script>
                <script>
            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
            (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
            m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
            })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
            ga('create', 'UA-73855-17', 'auto');
            ga('send', 'pageview'); 
        </script>

        <script>var isUserIsBot = true;</script>
        
    </head>
    
    
    <body itemscope="" itemtype="http://schema.org/WebPage">
        
            <header class="header">
                <nav class="navbar bg-primary">
                    <div class="container">
                        <div class="row align-items-center pt-4 pt-lg-0">
                            <div class="col-5 col-md-4 col-lg-3 col-xl-2 mr-xl-3 order-2 order-lg-1">
                                <a class="navbar-brand" href="https://techxplore.com/">
                                    <img src="https://techx.b-cdn.net/tmpl/v2/img/logotype.svg" alt="logotype">
                                </a>
                            </div>
                            <div class="col-auto px-lg-2 mt-2 mt-sm-0 ml-auto ml-lg-0  order-3 order-lg-2 d-print-none">
                                <button type="button" class="header-button" data-toggle="collapse" data-target="#collapseNavigation" aria-expanded="false" aria-controls="collapseNavigation">
                                    <span class="icon-nav"><span></span></span>
                                    <span class="d-none d-lg-block">Topics</span>
                                </button>
                            </div>
                            <div class="col-12 col-lg-7 col-xl-6 mb-sm-3 my-lg-0 ml-auto d-flex align-items-center order-1 order-lg-3 d-print-none">
                                <ul class="d-flex header-site-nav ml-lg-auto">
                                    <li class="nav-item">
                                        <a class="nav-link" href="https://techxplore.com/weekly-news/">Week's top</a>
                                    </li>
                                    <li class="nav-item">
                                        <a class="nav-link" href="https://techxplore.com/latest-news/">Latest news</a>
                                    </li>
                                    <li class="nav-item">
                                        <a class="nav-link" href="https://techxplore.com/unread-news/">Unread news</a>
                                    </li>
                                    <li class="nav-item">
                                        <a class="nav-link" href="#" data-toggle="modal" data-target="#subscribe">Subscribe</a>
                                    </li>
                                </ul>
                                <form class="header-search ml-auto ml-lg-0" action="https://techxplore.com/search/" method="get">
                                    <fieldset class="header-search__group">
                                        <input name="search" class="header-search__field" type="search" placeholder="Search" aria-label="Search">
                                        <button class="header-search__submit" type="submit">
                                            <svg>
                                                <use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#search" x="0" y="0"/>
                                            </svg>
                                        </button>
                                    </fieldset>
                                    <button type="button" class="header-search__show mr-4 mr-sm-5 mx-md-5">
                                        <svg>
                                            <use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#search" x="0" y="0"/>
                                        </svg>
                                    </button>
                                </form>
                                <div class="dropdown">
                                        <a class="header-account" href="#" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
        <svg>
            <use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_account" x="0" y="0"/>
        </svg>
            </a>
    <div class="dropdown-menu dropdown-menu-right dropdown-menu-tip fade mt-3" aria-labelledby="dropdownMenuButton">
                                        
            <div class="dropdown-content px-5 mx-5 py-4">
               <h3 class="text-extra-large font-weight-normal text-center text-nowrap mb-4">Science X Account</h3>
               <form method="post" action="https://sciencex.com/profile/login/">
                   <input type="hidden" name="status" value="login">
                   <input type="hidden" name="redirect" value="1">
                   <input type="hidden" name="ref" value="https://techxplore.com/news/2022-01-raspberry-pi-viruses-devices-software.html">
                   <div class="text-center px-lg-2">
                     <div class="mb-3">
                       <div data-focus="input" class="login-form-item">
                         <div class="login-form-icon">
                           <i class="icon login_field_email"></i>
                         </div>
                         <!-- icon -->
                         <input name="email" type="text" class="form-control input-styled input-email" placeholder="email" required="">
                       </div>
                     </div>
                     <!-- col -->
                     <div class="mb-3">
                       <div data-focus="input" class="login-form-item">
                         <div class="login-form-icon">
                           <i class="icon login_field_password"></i>
                         </div>
                         <!-- icon -->
                         <input name="password" type="password" class="form-control input-styled input-password" placeholder="password" required="">
                       </div>
                     </div>
                     <!-- col -->
                     <div class="mb-3 text-left">
                       <div data-focus="input" class="login-form-item">
                         <input class="modal-custom-form__checkbox bg-white" name="rememberMe" type="checkbox" id="log_persistent" checked="checked">
                         <label for="log_persistent">Remember me</label>
                       </div>
                     </div>
                     <!-- col -->
                     <div class="mt-2 mb-2 mb-lg-3">
                          <button type="submit" class="btn btn-sm btn-primary btn-block">Sign In</button>
                     </div>
                       <p class="mb-2 mb-lg-3">
                         <a href="https://sciencex.com/profile/login/" class="login-link">
                           Click here to sign in with
                               <svg>
                                   <use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#logo_fb" x="0" y="0"/>
                               </svg>
                                   or
                                <svg>
                                   <use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#logo_google" x="0" y="0"/>
                               </svg>
                         </a> 
                       </p>
                       <p class="mb-2 mb-lg-3">
                         <a href="https://sciencex.com/profile/pwdreset/">Forget Password?</a>
                       </p>
                       <div class="mb-2 mb-lg-3">
                         <a href="https://sciencex.com/profile/register/" class="btn btn-sm btn-white btn-block">Not a member?
                           <b>Sign up</b>
                         </a>
                       </div>
                       <p>
                           <a class="font-weight-normal" href="https://sciencex.com/help/account/">Learn more</a>
                       </p>
                     </div>
                     <!-- col -->
                   </div>
                   <!-- row -->
                  </form>
            </div>
                               
    </div>
    <!-- //dropdown -->
                                  
                                </div>                        
                            </div>
                        </div>
                    </div>
                </nav>
                <nav class="collapse header-collapse bg-secondary d-print-none" id="collapseNavigation">
                    <div class="container py-3">
                            <ul class="d-flex header-articles-nav justify-content-between flex-wrap">
                <li class="nav-item">
                <a class="nav-link" href="https://techxplore.com/automotive-news/">Automotive</a>
            </li>                   
                <li class="nav-item">
                <a class="nav-link" href="https://techxplore.com/business-tech-news/">Business</a>
            </li>                   
                <li class="nav-item">
                <a class="nav-link" href="https://techxplore.com/computer-sciences-news/">Computer Sciences</a>
            </li>                   
                <li class="nav-item">
                <a class="nav-link" href="https://techxplore.com/consumer-gadgets-news/">Consumer & Gadgets</a>
            </li>                   
                <li class="nav-item">
                <a class="nav-link" href="https://techxplore.com/semiconductors-news/">Electronics & Semiconductors</a>
            </li>                   
                <li class="nav-item">
                <a class="nav-link" href="https://techxplore.com/energy-green-tech-news/">Energy & Green Tech</a>
            </li>                   
                <li class="nav-item">
                <a class="nav-link" href="https://techxplore.com/engineering-news/">Engineering</a>
            </li>                   
                <li class="nav-item">
                <a class="nav-link" href="https://techxplore.com/hardware-news/">Hardware</a>
            </li>                   
                <li class="nav-item">
                <a class="nav-link" href="https://techxplore.com/hi-tech-news/">Hi Tech & Innovation</a>
            </li>                   
                <li class="nav-item">
                <a class="nav-link" href="https://techxplore.com/internet-news/">Internet</a>
            </li>                   
                <li class="nav-item">
                <a class="nav-link" href="https://techxplore.com/machine-learning-ai-news/">Machine learning & AI</a>
            </li>                   
                <li class="nav-item">
                <a class="nav-link" href="https://techxplore.com/other-news/">Other</a>
            </li>                   
                <li class="nav-item">
                <a class="nav-link" href="https://techxplore.com/robotics-news/">Robotics</a>
            </li>                   
                <li class="nav-item">
                <a class="nav-link" href="https://techxplore.com/security-news/">Security</a>
            </li>                   
                <li class="nav-item">
                <a class="nav-link" href="https://techxplore.com/software-news/">Software</a>
            </li>                   
                <li class="nav-item">
                <a class="nav-link" href="https://techxplore.com/telecom-news/">Telecom</a>
            </li>                   
        </ul>

                    </div>
                </nav>
            </header>
            


        

        
	<main class="bg-white news">
		<div class="container py-5">
            			<div class="row">
                <div class="col-2 mt-md-5 d-print-none">
					<ul class="soc pt-md-3" id="js-soc-panel">
						<li class="d-block d-md-none soc-panel-close">
							<button type="button">
								<svg>
									<use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_close" x="0" y="0"/>
								</svg>
							</button>
						</li>
						<li class="d-block d-md-none">
							<p class="text-white text-low-up mb-0">share this!</p>
						</li>
						<li>
							<a href="javascript:void(0)" class="soc-link fb">
								<svg class="soc-link__icon">
									<use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_fb_news" x="0" y="0"/>
								</svg>
								<p class="text-low">486</p>
							</a>
						</li>
						<li>
							<a href="#" class="soc-link tw"  data-title="Raspberry Pi system can detect viruses on other devices without use of software" data-via="techxplore_com">
								<svg class="soc-link__icon">
									<use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_twit_news" x="0" y="0"/>
								</svg>
								<p class="text-low">41</p>
							</a>
						</li>
						<li>
							<a href="#" class="soc-link ln">
								<svg class="soc-link__icon">
									<use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_linkedin" x="0" y="0"/>
								</svg>
								<p class="text-low">Share</p>
							</a>
						</li>
						<li>
							<a href="mailto:" class="soc-link" data-toggle="modal" data-target="#feedback-email">
								<svg class="soc-link__icon">
									<use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_mail_news" x="0" y="0"/>
								</svg>
								<p class="text-low">Email</p>
							</a>
						</li>
					</ul>
				</div>
                
                <div class="col-md-10 col-lg-6">
					<section class="article">
						<div class="row">
							<div class="col-9 col-md-9 col-xl-10">
                                <nav aria-label="breadcrumb">
                                                                        <ol class="breadcrumb bg-white mb-0 p-0">
                                       <li class="breadcrumb-item">
                                        <a href="/" rel="home"><span class="text-muted text-low-up">Home</span></a>
                                       </li>
                                       <li class="breadcrumb-item active">
                                            <a href="https://techxplore.com/security-news/">
                                                <span class="text-muted text-low-up">Security</span>
                                            </a>
                                       </li>
                                    </ol>
                                                                    </nav>
							</div>
                            <div class="col-3 col-xl-2 d-print-none">
								<ul class="article-actions">
									<li class="article-actions__item">
										<a href="javascript:void(0)"  data-nid="561115672" id="fav">
											<svg>
												<use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_addfav" x="0" y="0"/>
											</svg>
										</a>
									</li>
									<li class="article-actions__item">
										<a href="https://techxplore.com/pdf561115672.pdf" title="Save as pdf file" title="Add bookmark to Science X account">
											<svg>
												<use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_pdf" x="0" y="0"/>
											</svg>
										</a>
									</li>
									<li class="article-actions__item">
										<a href="javascript:window.print()" title="Print">
											<svg>
												<use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_print" x="0" y="0"/>
											</svg>
										</a>
									</li>
								</ul>
							</div>
                            <div class="col-12 mt-2 mt-xl-3">
								<hr>
							</div>
                            
                            
                            <div class="col-12 mt-3 mb-5 mb-lg-0">
								<article class="news-article">
									<div class="article__info mb-2">
										<div class="article__info-item mr-auto">
											<svg class="article__info-icon">
												<use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"/>
											</svg>
											<p class="text-uppercase text-low">
                                                January 11, 2022
                                                <span class="ml-2 badge a_report">report</span>
                 				
                                            </p>
										</div>
									</div>
									<h1 class="text-extra-large line-low mb-2">Raspberry Pi system can detect viruses on other devices without use of software</h1>
                                    <p class="article-byline text-low">
                                        by Bob Yirka                                                                                , Tech Xplore
                                                                            </p>
                                    <div class="mt-4 text-low-up text-regular article-main">
									    <div class="article-gallery lightGallery">
    <div data-thumb="https://scx1.b-cdn.net/csz/news/tmb/2022/raspberry-pi.jpg" data-src="https://scx2.b-cdn.net/gfx/news/hires/2022/raspberry-pi.jpg" data-sub-html="Credit: Unsplash/CC0 Public Domain">
        <figure class="article-img">
            <img src="https://scx1.b-cdn.net/csz/news/800a/2022/raspberry-pi.jpg"
                 alt="Raspberry Pi"
                 title="Credit: Unsplash/CC0 Public Domain" 
                 width="800" height="450">
             <figcaption class="text-darken text-low-up text-truncate-js text-truncate mt-3">
                Credit: Unsplash/CC0 Public Domain
            </figcaption>        </figure>
    </div>
</div><p>A team of researchers at the Institute of Computer Science and Random Systems has built a non-software-based virus detection system using a Raspberry Pi, an H-field probe and an oscilloscope to detect electromagnetic wave signatures of multiple types of viruses. The team presented its system and test results at last month's ACM Machinery's Annual Computer Security Applications Conference and <a href="https://dl.acm.org/doi/abs/10.1145/3485832.3485894">published a paper</a> describing their system on ACM's Research Article page.
                                              <div class="article-banner ads-336x280">
        <!-- /4988204/TechX_Story_InText_Box -->
        <div id='div-gpt-ad-1453799284784-2'>
        <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1453799284784-2'); });
        </script>
        </div>
      </div>
                                                                                <p>The idea behind the new <a href="https://techxplore.com/tags/system/" rel="tag" class="textTag">system</a> is that running software generates <a href="https://techxplore.com/tags/electromagnetic+waves/" rel="tag" class="textTag">electromagnetic waves</a>. And each piece of software generates its own unique wave patterns due to the way the software executes its code. The researchers took advantage of this knowledge and began using an H-field probe to capture wave patterns of known <a href="https://techxplore.com/tags/computer+viruses/" rel="tag" class="textTag">computer viruses</a> running on various devices and viewed the results on an oscilloscope. They saw oscilloscope patterns that were unique to individual viruses as they were running. The researchers used that information to program a Raspberry Pi to identify data from the other two devices to recognize known virus wave patterns, using the system as a virus detector. To determine if a virus is running on a computer, IoT device or smartphone, a user places the H-field probe close enough to the device to read the electromagnetic waves that are generated. The Raspberry Pi then reports on whether it found any viruses, and if so, which ones. Testing found the system capable of detecting 99.82% of generic malware, along with a benign virus type.</p>
<p>The system is notable because it does not require <a href="https://techxplore.com/tags/software/" rel="tag" class="textTag">software</a> installation on the device being tested—detection is done using the external system. It is also notable because it is not susceptible to obfuscation techniques developed by the virus builders to hide its presence. Such a system is not likely to be sold to consumers, however, but it could very well be used for large applications or servers.
                                                                                                                        <hr>										
                                        <div class="article-main__explore my-4 d-print-none">
											<div class="d-flex align-items-center">
												<svg>
													<use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#plus" x="0" y="0"/>
												</svg>
												<p class="text-bold mb-0 ml-2">Explore further</p>
											</div>
                                            <a class="text-medium text-info mt-2 d-inline-block" href="https://techxplore.com/news/2021-07-malware-android-source-code.html">New malware detection for Android at the source code level</a>
										</div>										
                                        <hr class="mb-4">
                                                                                											<div class="article-main__more p-4">
																								<strong>More information:</strong>
												Duy-Phuc Pham et al, Obfuscation Revealed: Leveraging Electromagnetic Signals for Obfuscated Malware Classification, <i>Annual Computer Security Applications Conference</i> (2021).  <a data-doi="1" href="http://dx.doi.org/10.1145/3485832.3485894" target="_blank">DOI: 10.1145/3485832.3485894</a>
																								
																							</div>
                                        											
										                                                                                    <p class="article-main__note mt-4">
                                                © 2022 Science X Network
                                            </p>
                                                                                
                                        <!-- print only -->
                                        <div class="d-none d-print-block">
                                            <div class="mb-4">
                                                 <strong>Citation</strong>:
                                                 Raspberry Pi system can detect viruses on other devices without use of software (2022, January 11)
                                                 retrieved 13 January 2022
                                                 from https://techxplore.com/news/2022-01-raspberry-pi-viruses-devices-software.html
                                            </div>
                                            <div class="border text-muted p-3">
                                            This document is subject to copyright. Apart from any fair dealing for the purpose of private study or research, no
                                            part may be reproduced without the written permission. The content is provided for information purposes only.
                                            </div>
                                        </div>
                                        
									</div>
								</article>
								<div class="article-interaction my-4 d-flex align-items-center d-print-none">
                                   
									<a href="javascript:void(0)" class="btn btn-info px-4 py-2 text-regular border-0 mr-4"><span>530</span>&nbsp;shares</a>
                                    
									<ul class="ml-md-auto ml-sm-0 article-interaction__social d-flex">
										<li>
											<a href="javascript:void(0)" class="article-interaction__link fb">
												<svg>
													<use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_fb_news" x="0" y="0"/>
												</svg>
												<p class="text-regular mb-0">Facebook</p>
											</a>
										</li>
                                        <li>
											<a href="#" class="article-interaction__link tw" data-title="Raspberry Pi system can detect viruses on other devices without use of software" data-via="techxplore_com">
												<svg>
													<use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_twit_news" x="0" y="0"/>
												</svg>
												<p class="text-regular mb-0">Twitter</p>
											</a>
										</li>
										<li>
											<a href="#" class="article-interaction__link" data-toggle="modal" data-target="#feedback-email">
												<svg>
													<use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_mail_news" x="0" y="0"/>
												</svg>
												<p class="text-regular mb-0">Email</p>
											</a>
										</li>
									</ul>
									<a href="#" class="ml-auto mt-lg-4 mt-xl-0 article-interaction__link" data-toggle="modal" data-target="#feedback-to-editors">
										<svg>
											<use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_feedback" x="0" y="0"/>
										</svg>
										<p class="text-regular mb-0"> Feedback to editors</p>
									</a>
								</div>
                                
                                      <div class="bf-banner">
        <!-- /4988204/TechX_Story_Below_Rectangle -->
        <div id='div-gpt-ad-1453799284784-1'>
        <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1453799284784-1'); });
        </script>
        </div>
      </div>
                                
							</div>                            
                        </div>
                    </section>
                </div>
                
                <!-- aside -->
                <div class="offset-xl-1 col-md col-lg-4 col-xl-3 article-sidebar d-none d-lg-block d-print-none">
					      <div class="article-sidebar-banner ads-336x280">
        <!-- /4988204/TechX_Story_Right_Box -->
        <div id='div-gpt-ad-1453799284784-3'>
        <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1453799284784-3'); });
        </script>
        </div>
      </div>




                
                    <div class="row">
                        <div class="col">
                            <aside class="categories">
                                <ul class="categories-controls nav justify-content-between" role="tablist">
                                    <li class="categories-controls__item">
                                        <a class="active" id="nav-featured-tab" data-toggle="tab" href="#nav-featured" role="tab" aria-controls="nav-featured" aria-selected="true">Featured</a>
                                    </li>
                                    <li class="categories-controls__item">
                                        <a id="nav-comments-tab" data-toggle="tab" href="#nav-commented" role="tab" aria-controls="nav-commented" aria-selected="false">Last Comments</a>
                                    </li>
                                    <li class="categories-controls__item">
                                        <a id="nav-popular-tab" data-toggle="tab" href="#nav-popular" role="tab" aria-controls="nav-popular" aria-selected="false">Popular</a>	
                                    </li>
                                </ul>
                                <div class="categories-content tab-content pt-4">
                                    <div class="categories-content__pane tab-pane fade show active" id="nav-featured" role="tabpanel" aria-labelledby="nav-featured-tab" data-loaded="true">
                                                 
            <article class="categories-content__item">
                <h4><a href="https://techxplore.com/news/2022-01-raspberry-pi-viruses-devices-software.html">Raspberry Pi system can detect viruses on other devices without use of software</a></h4>
                <div class="article__info">
                          <div class="article__info-item mr-auto">
                                  <svg class="article__info-icon">
                                          <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"/>
                                  </svg>
                                  <p class="text-uppercase text-low">Jan 11, 2022</p>
                          </div>
                          <div class="article__info-item mr-3">
                                  <svg class="article__info-icon">
                                          <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_comment" x="0" y="0"/>
                                  </svg>
                                  <p class="text-uppercase text-low"><span>1</span></p>
                          </div>
                  </div>
            </article>
         
            <article class="categories-content__item">
                <h4><a href="https://techxplore.com/news/2022-01-cta-availability-ripplean-radar-api.html">CTA announces availability of Ripple—an open radar API standard</a></h4>
                <div class="article__info">
                          <div class="article__info-item mr-auto">
                                  <svg class="article__info-icon">
                                          <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"/>
                                  </svg>
                                  <p class="text-uppercase text-low">Jan 11, 2022</p>
                          </div>
                          <div class="article__info-item mr-3">
                                  <svg class="article__info-icon">
                                          <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_comment" x="0" y="0"/>
                                  </svg>
                                  <p class="text-uppercase text-low"><span>0</span></p>
                          </div>
                  </div>
            </article>
         
            <article class="categories-content__item">
                <h4><a href="https://techxplore.com/news/2022-01-concurrent-transmission-strategy-multi-robot-cooperation.html">A concurrent transmission strategy to enhance multi-robot cooperation</a></h4>
                <div class="article__info">
                          <div class="article__info-item mr-auto">
                                  <svg class="article__info-icon">
                                          <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"/>
                                  </svg>
                                  <p class="text-uppercase text-low">Jan 10, 2022</p>
                          </div>
                          <div class="article__info-item mr-3">
                                  <svg class="article__info-icon">
                                          <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_comment" x="0" y="0"/>
                                  </svg>
                                  <p class="text-uppercase text-low"><span>0</span></p>
                          </div>
                  </div>
            </article>
         
            <article class="categories-content__item">
                <h4><a href="https://techxplore.com/news/2022-01-silicon-photonic-electronic-neural-network-submarine.html">A silicon photonic-electronic neural network that could enhance submarine transmission systems</a></h4>
                <div class="article__info">
                          <div class="article__info-item mr-auto">
                                  <svg class="article__info-icon">
                                          <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"/>
                                  </svg>
                                  <p class="text-uppercase text-low">Jan 07, 2022</p>
                          </div>
                          <div class="article__info-item mr-3">
                                  <svg class="article__info-icon">
                                          <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_comment" x="0" y="0"/>
                                  </svg>
                                  <p class="text-uppercase text-low"><span>1</span></p>
                          </div>
                  </div>
            </article>
         
            <article class="categories-content__item">
                <h4><a href="https://techxplore.com/news/2022-01-google-docs-comment-feature-exploited.html">Google Docs comment feature exploited to distribute phishing links</a></h4>
                <div class="article__info">
                          <div class="article__info-item mr-auto">
                                  <svg class="article__info-icon">
                                          <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"/>
                                  </svg>
                                  <p class="text-uppercase text-low">Jan 07, 2022</p>
                          </div>
                          <div class="article__info-item mr-3">
                                  <svg class="article__info-icon">
                                          <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_comment" x="0" y="0"/>
                                  </svg>
                                  <p class="text-uppercase text-low"><span>0</span></p>
                          </div>
                  </div>
            </article>
        
                                    </div>
                                    <div class="categories-content__pane tab-pane fade" id="nav-commented" role="tabpanel" aria-labelledby="nav-commented-tab">
                                        
                                    </div>
                                    <div class="categories-content__pane tab-pane fade" id="nav-popular" role="tabpanel" aria-labelledby="nav-popular-tab">
                                        
                                    </div>
                                </div>
                            </aside>
                        </div>
                    </div>
                    
                    <hr>
                    
                    <div class="row mt-4">
						<div class="col-12">
							         
            <a href="https://techxplore.com/news/2022-01-cycle-lithium-sulfur-battery-quintuple-electric.html" class="selection-link">
                <article class="selection-article">
                        <figure class="selection-article__figure">
                                <img class="selection-article__image" data-src="https://scx1.b-cdn.net/csz/news/tmb/2022/1000-cycle-lithium-sul.jpg" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" alt="">                                <figcaption class="selection-article__description">
                                        <h5>1,000-cycle lithium-sulfur battery could quintuple electric vehicle ranges</h5>
                                        <div class="article__info">
                                                <div class="article__info-item">
                                                        <svg class="article__info-icon">
                                                                <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"></use>
                                                        </svg>
                                                        <p class="text-uppercase text-low">11 hours ago</p>
                                                </div>
                                        </div>
                                </figcaption>
                        </figure>
                </article>
           </a>
         
            <a href="https://techxplore.com/news/2022-01-rubber-material-key-long-lasting-safer.html" class="selection-link">
                <article class="selection-article">
                        <figure class="selection-article__figure">
                                <img class="selection-article__image" data-src="https://scx1.b-cdn.net/csz/news/tmb/2022/rubber-material-holds.jpg" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" alt="">                                <figcaption class="selection-article__description">
                                        <h5>Rubber material holds key to long-lasting, safer EV batteries</h5>
                                        <div class="article__info">
                                                <div class="article__info-item">
                                                        <svg class="article__info-icon">
                                                                <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"></use>
                                                        </svg>
                                                        <p class="text-uppercase text-low">11 hours ago</p>
                                                </div>
                                        </div>
                                </figcaption>
                        </figure>
                </article>
           </a>
         
            <a href="https://techxplore.com/news/2022-01-molecular-paddlewheels-propel-sodium-ions.html" class="selection-link">
                <article class="selection-article">
                        <figure class="selection-article__figure">
                                <img class="selection-article__image" data-src="https://scx1.b-cdn.net/csz/news/tmb/2022/molecular-paddlewheels.jpg" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" alt="">                                <figcaption class="selection-article__description">
                                        <h5>Molecular paddlewheels propel sodium ions through next-generation batteries</h5>
                                        <div class="article__info">
                                                <div class="article__info-item">
                                                        <svg class="article__info-icon">
                                                                <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"></use>
                                                        </svg>
                                                        <p class="text-uppercase text-low">Jan 11, 2022</p>
                                                </div>
                                        </div>
                                </figcaption>
                        </figure>
                </article>
           </a>
         
            <a href="https://techxplore.com/news/2022-01-idirect-network-framework-scientists-biological.html" class="selection-link">
                <article class="selection-article">
                        <figure class="selection-article__figure">
                                <img class="selection-article__image" data-src="https://scx1.b-cdn.net/csz/news/tmb/2021/network.jpg" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" alt="">                                <figcaption class="selection-article__description">
                                        <h5>iDIRECT network framework could help scientists better understand biological systems</h5>
                                        <div class="article__info">
                                                <div class="article__info-item">
                                                        <svg class="article__info-icon">
                                                                <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"></use>
                                                        </svg>
                                                        <p class="text-uppercase text-low">Jan 11, 2022</p>
                                                </div>
                                        </div>
                                </figcaption>
                        </figure>
                </article>
           </a>
         
            <a href="https://techxplore.com/news/2022-01-greenhouse-gas-fuel.html" class="selection-link">
                <article class="selection-article">
                        <figure class="selection-article__figure">
                                <img class="selection-article__image" data-src="https://scx1.b-cdn.net/csz/news/tmb/2022/why-some-attempts-to-c.jpg" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" alt="">                                <figcaption class="selection-article__description">
                                        <h5>Why some attempts to convert the greenhouse gas into fuel have failed</h5>
                                        <div class="article__info">
                                                <div class="article__info-item">
                                                        <svg class="article__info-icon">
                                                                <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"></use>
                                                        </svg>
                                                        <p class="text-uppercase text-low">Jan 11, 2022</p>
                                                </div>
                                        </div>
                                </figcaption>
                        </figure>
                </article>
           </a>
         
            <a href="https://techxplore.com/news/2022-01-2d-3d-inflate-machine.html" class="selection-link">
                <article class="selection-article">
                        <figure class="selection-article__figure">
                                <img class="selection-article__image" data-src="https://scx1.b-cdn.net/csz/news/tmb/2022/from-2d-to-3d--how-to.jpg" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" alt="">                                <figcaption class="selection-article__description">
                                        <h5>From 2D to 3D: How to inflate shapes via machine learning</h5>
                                        <div class="article__info">
                                                <div class="article__info-item">
                                                        <svg class="article__info-icon">
                                                                <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"></use>
                                                        </svg>
                                                        <p class="text-uppercase text-low">Jan 11, 2022</p>
                                                </div>
                                        </div>
                                </figcaption>
                        </figure>
                </article>
           </a>
         
            <a href="https://techxplore.com/news/2022-01-misinformation-countermeasures.html" class="selection-link">
                <article class="selection-article">
                        <figure class="selection-article__figure">
                                <img class="selection-article__image" data-src="https://scx1.b-cdn.net/csz/news/tmb/2022/computer-model-seeks-t.jpg" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" alt="">                                <figcaption class="selection-article__description">
                                        <h5>Computer model seeks to explain the spread of misinformation and suggest countermeasures</h5>
                                        <div class="article__info">
                                                <div class="article__info-item">
                                                        <svg class="article__info-icon">
                                                                <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"></use>
                                                        </svg>
                                                        <p class="text-uppercase text-low">Jan 11, 2022</p>
                                                </div>
                                        </div>
                                </figcaption>
                        </figure>
                </article>
           </a>
        
                        </div>
                    </div>
                    
                </div>
                <!-- /aside -->
                
            </div>
        </div>
        <!-- /container -->
        
        <section class="news-related bg-light py-5 d-print-none">
			<div class="container">
				<div class="row">
					<div class="col-md-10 offset-md-2">
						<div class="js-news-related__wrap d-flex align-items-center justify-content-between">
							<h2 class="text-extra-large text-medium"></h2>
						</div>
					</div>                    
                    <div class="col-md-10 offset-md-2">
                        						<ul id="js-news-related-slider" class="news-related__slider">
							<li class="row no-gutters">
                                <div class="col-12 mb-5">
                                    <h2 class="text-extra-large text-medium">Related Stories</h2>
                                </div>
								<div class="col-6">									
                                             
            <a href="https://techxplore.com/news/2021-07-malware-android-source-code.html" class="selection-link">
                <article class="selection-article">
                        <figure class="selection-article__figure">
                                <img class="selection-article__image" data-src="https://scx1.b-cdn.net/csz/news/tmb/2021/android-phone.jpg" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" alt="">                                <figcaption class="selection-article__description">
                                        <h5>New malware detection for Android at the source code level</h5>
                                        <div class="article__info">
                                                <div class="article__info-item">
                                                        <svg class="article__info-icon">
                                                                <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"></use>
                                                        </svg>
                                                        <p class="text-uppercase text-low">Jul 23, 2021</p>
                                                </div>
                                        </div>
                                </figcaption>
                        </figure>
                </article>
           </a>
         
            <a href="https://medicalxpress.com/news/2020-12-smartphone-camera-viral-infections.html" class="selection-link">
                <article class="selection-article">
                        <figure class="selection-article__figure">
                                <img class="selection-article__image" data-src="https://scx1.b-cdn.net/csz/news/tmb/2020/5fdb47f2d1b4b.jpg" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" alt="">                                <figcaption class="selection-article__description">
                                        <h5>Smartphone camera used to diagnose viral infections</h5>
                                        <div class="article__info">
                                                <div class="article__info-item">
                                                        <svg class="article__info-icon">
                                                                <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"></use>
                                                        </svg>
                                                        <p class="text-uppercase text-low">Dec 17, 2020</p>
                                                </div>
                                        </div>
                                </figcaption>
                        </figure>
                </article>
           </a>
         
            <a href="https://techxplore.com/news/2021-10-raspberry-pi-hatan-add-on-device.html" class="selection-link">
                <article class="selection-article">
                        <figure class="selection-article__figure">
                                <img class="selection-article__image" data-src="https://scx1.b-cdn.net/csz/news/tmb/2021/raspberry-pi-announces.jpg" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" alt="">                                <figcaption class="selection-article__description">
                                        <h5>Raspberry Pi announces Build HAT—an add-on device that uses Pi hardware to control LEGO Technic motors</h5>
                                        <div class="article__info">
                                                <div class="article__info-item">
                                                        <svg class="article__info-icon">
                                                                <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"></use>
                                                        </svg>
                                                        <p class="text-uppercase text-low">Oct 20, 2021</p>
                                                </div>
                                        </div>
                                </figcaption>
                        </figure>
                </article>
           </a>
                                            
                                </div>
                                <div class="col-6">									
                                             
            <a href="https://phys.org/news/2021-11-rapid-highly-accurate-viruses-sars-cov-.html" class="selection-link">
                <article class="selection-article">
                        <figure class="selection-article__figure">
                                <img class="selection-article__image" data-src="https://scx1.b-cdn.net/csz/news/tmb/2021/dna-test.jpg" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" alt="">                                <figcaption class="selection-article__description">
                                        <h5>Researchers develop rapid, highly accurate test to detect viruses like SARS-COV-2</h5>
                                        <div class="article__info">
                                                <div class="article__info-item">
                                                        <svg class="article__info-icon">
                                                                <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"></use>
                                                        </svg>
                                                        <p class="text-uppercase text-low">Nov 29, 2021</p>
                                                </div>
                                        </div>
                                </figcaption>
                        </figure>
                </article>
           </a>
         
            <a href="https://techxplore.com/news/2021-07-malware-ai-neural-networks.html" class="selection-link">
                <article class="selection-article">
                        <figure class="selection-article__figure">
                                <img class="selection-article__image" data-src="https://scx1.b-cdn.net/csz/news/tmb/2018/malware.jpg" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" alt="">                                <figcaption class="selection-article__description">
                                        <h5>Hiding malware inside AI neural networks</h5>
                                        <div class="article__info">
                                                <div class="article__info-item">
                                                        <svg class="article__info-icon">
                                                                <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"></use>
                                                        </svg>
                                                        <p class="text-uppercase text-low">Jul 27, 2021</p>
                                                </div>
                                        </div>
                                </figcaption>
                        </figure>
                </article>
           </a>
         
            <a href="https://sciencex.com/news/2021-05-shape-shifting-chip-thwarts-army-ofhackers.html" class="selection-link">
                <article class="selection-article">
                        <figure class="selection-article__figure">
                                <img class="selection-article__image" data-src="https://scx1.b-cdn.net/csz/news/tmb/2021/shape-shifting-compute.jpg" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" alt="">                                <figcaption class="selection-article__description">
                                        <h5>Shape-shifting computer chip thwarts an army of hackers</h5>
                                        <div class="article__info">
                                                <div class="article__info-item">
                                                        <svg class="article__info-icon">
                                                                <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"></use>
                                                        </svg>
                                                        <p class="text-uppercase text-low">May 25, 2021</p>
                                                </div>
                                        </div>
                                </figcaption>
                        </figure>
                </article>
           </a>
                                            
                                </div>
                            </li>
                            <li class="row no-gutters">
                                <div class="col-12 mb-5">
                                    <h2 class="text-extra-large text-medium">Recommended for you</h2>
                                </div>
                                <div class="col-6">									
                                             
            <a href="https://techxplore.com/news/2022-01-google-docs-comment-feature-exploited.html" class="selection-link">
                <article class="selection-article">
                        <figure class="selection-article__figure">
                                <img class="selection-article__image" data-src="https://scx1.b-cdn.net/csz/news/tmb/2021/drgoogle.jpg" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" alt="">                                <figcaption class="selection-article__description">
                                        <h5>Google Docs comment feature exploited to distribute phishing links</h5>
                                        <div class="article__info">
                                                <div class="article__info-item">
                                                        <svg class="article__info-icon">
                                                                <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"></use>
                                                        </svg>
                                                        <p class="text-uppercase text-low">Jan 07, 2022</p>
                                                </div>
                                        </div>
                                </figcaption>
                        </figure>
                </article>
           </a>
         
            <a href="https://techxplore.com/news/2022-01-bug-backup-software-results-loss.html" class="selection-link">
                <article class="selection-article">
                        <figure class="selection-article__figure">
                                <img class="selection-article__image" data-src="https://scx1.b-cdn.net/csz/news/tmb/2021/data-1.jpg" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" alt="">                                <figcaption class="selection-article__description">
                                        <h5>Bug in backup software results in loss of 77 terabytes of research data at Kyoto University</h5>
                                        <div class="article__info">
                                                <div class="article__info-item">
                                                        <svg class="article__info-icon">
                                                                <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"></use>
                                                        </svg>
                                                        <p class="text-uppercase text-low">Jan 04, 2022</p>
                                                </div>
                                        </div>
                                </figcaption>
                        </figure>
                </article>
           </a>
         
            <a href="https://techxplore.com/news/2021-12-router-home-intercepting-internet-trafficbut.html" class="selection-link">
                <article class="selection-article">
                        <figure class="selection-article__figure">
                                <img class="selection-article__image" data-src="https://scx1.b-cdn.net/csz/news/tmb/2014/dns.png" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" alt="">                                <figcaption class="selection-article__description">
                                        <h5>The router in your home might be intercepting some of your Internet traffic—but it may be for your own good</h5>
                                        <div class="article__info">
                                                <div class="article__info-item">
                                                        <svg class="article__info-icon">
                                                                <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"></use>
                                                        </svg>
                                                        <p class="text-uppercase text-low">Dec 15, 2021</p>
                                                </div>
                                        </div>
                                </figcaption>
                        </figure>
                </article>
           </a>
                                            
                                </div>
                                <div class="col-6">									
                                             
            <a href="https://techxplore.com/news/2021-12-scientists-framework-browsers-zero-day-vulnerabilities.html" class="selection-link">
                <article class="selection-article">
                        <figure class="selection-article__figure">
                                <img class="selection-article__image" data-src="https://scx1.b-cdn.net/csz/news/tmb/2021/firefox.jpg" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" alt="">                                <figcaption class="selection-article__description">
                                        <h5>Computer scientists develop a framework to protect browsers from zero-day vulnerabilities in third-party libraries</h5>
                                        <div class="article__info">
                                                <div class="article__info-item">
                                                        <svg class="article__info-icon">
                                                                <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"></use>
                                                        </svg>
                                                        <p class="text-uppercase text-low">Dec 07, 2021</p>
                                                </div>
                                        </div>
                                </figcaption>
                        </figure>
                </article>
           </a>
         
            <a href="https://techxplore.com/news/2021-12-fourteen-web-browsers.html" class="selection-link">
                <article class="selection-article">
                        <figure class="selection-article__figure">
                                <img class="selection-article__image" data-src="https://scx1.b-cdn.net/csz/news/tmb/2021/14-new-attacks-on-web.jpg" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" alt="">                                <figcaption class="selection-article__description">
                                        <h5>Fourteen new types of attacks on web browsers detected</h5>
                                        <div class="article__info">
                                                <div class="article__info-item">
                                                        <svg class="article__info-icon">
                                                                <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"></use>
                                                        </svg>
                                                        <p class="text-uppercase text-low">Dec 02, 2021</p>
                                                </div>
                                        </div>
                                </figcaption>
                        </figure>
                </article>
           </a>
         
            <a href="https://techxplore.com/news/2021-11-server-decentralizing-group-messaging.html" class="selection-link">
                <article class="selection-article">
                        <figure class="selection-article__figure">
                                <img class="selection-article__image" data-src="https://scx1.b-cdn.net/csz/news/tmb/2017/messaging.jpg" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" alt="">                                <figcaption class="selection-article__description">
                                        <h5>Beyond one server: Decentralizing secure group messaging</h5>
                                        <div class="article__info">
                                                <div class="article__info-item">
                                                        <svg class="article__info-icon">
                                                                <use xlink:href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_clock" x="0" y="0"></use>
                                                        </svg>
                                                        <p class="text-uppercase text-low">Nov 24, 2021</p>
                                                </div>
                                        </div>
                                </figcaption>
                        </figure>
                </article>
           </a>
                                            
                                </div>
                            </li>
                        </ul>
                    </div>
                </div>
            </div>
        </section>
        <!-- /related -->
        
        <div class="container d-print-none">    
    <div class="embed-responsive embed-responsive-trendmd">
        <iframe class="embed-responsive-item"
            sandbox="allow-scripts allow-same-origin allow-popups"
            allowfullscreen
            src="//js.trendmd.com/trendmd.amp.html?title=Raspberry%20Pi%20system%20can%20detect%20viruses%20on%20other%20devices%20without%20use%20of%20software&url=https%3A%2F%2Ftechxplore.com%2Fnews%2F2022-01-raspberry-pi-viruses-devices-software.html&journalId=73746">
        </iframe>
    </div>
</div>
        
        <div class="comments-wrapper-new" data-story-id="561115672">
            <div class="container">
                <div class="row">
                    <div class="col-md-12 col-lg-10 offset-lg-2 article-interaction my-4 d-flex align-items-center d-print-none">
                        <section class="my-4 text-center w-75">
									 <a href="Javascript:void(0);" class="btn btn-info border-bold text-low-up px-5 load-comments" data-toggle="modal" data-target="#commentsModal">
										Load comments (1)
									 </a>
							  </section>
                    </div>
                </div>
            </div>
        </div>
        <!-- /comments -->
        
        <section id="news-more" class="news-related bg-light py-5 d-lg-none d-print-none" data-ads="Y"></section>
        <!-- /news-more -->
        
        
        <!-- modal -->
        <div class="modal fade modal-custom d-print-none" tabindex="-1" role="dialog" id="feedback-to-editors">
            <div class="modal-dialog" role="document">
                <div class="modal-content">
                    <div class="modal-header">
                        <h5 class="modal-title text-center">Let us know if there is a problem with our content</h5>
                         <button class="modal-custom__close" type="button" data-dismiss="modal" aria-label="Close">
                            <svg>
                                <use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_close" x="0" y="0"/>
                            </svg>
                        </button>
                    </div>
                    <form class="modal-custom-form" name="feedback" action="https://sciencex.com/api/story/feedback/561115672/" novalidate>
                        <div class="modal-body">                        
                            <div class="form-group">
										
										<p class="article-main__more p-4 mb-4">
											Use this form if you have come across a typo, inaccuracy or would like to send an edit request for the content on this page.
											For general inquiries, please use our  <a href="https://sciencex.com/help/feedback/" target="_blank">contact form</a>.
											For general feedback, use the public comments section below (please <a href="https://sciencex.com/help/comments/" target="_blank">adhere to guidelines</a>).
										</p>
										
										<p>Please select the most appropriate category to facilitate processing of your request</p>
										<select name="type" class="form-control" required>
										  <optgroup>
											  <option hidden disabled selected value="spam"> -- please select one -- </option>
											  <option value="general">Compliments / Critique</option>
											  <option value="typo">Typos / Errors / Inaccuracies</option>
											  <option value="request">Edit / Removal request</option>
										  </optgroup>
										</select>
									 </div>
									 <div class="form-group">
                                <label for="modal-feedback-message">Your message to the editors</label>
                                <textarea name="comments" class="form-control no-resize" id="modal-feedback-message" rows="6" required></textarea>
                            </div>
                            <div class="row align-items-end">
                                <div class="col-md-7">
                                    <div class="form-group mb-0">
                                        <label for="modal-feedback-email">Your  email  (only if you want to be contacted back)</label>
                                        <input type="email" name="emailFrom" class="form-control form-control-lg" id="modal-feedback-email" placeholder="optional">
                                    </div>
                                </div>
                                <div class="col-md-auto ml-auto text-center text-md-left mt-4 mt-md-0">
                                    <button type="submit" class="btn btn-warning text-bold text-low-up px-5">Send Feedback</button>
                                </div>
                            </div>
                        </div>
                        <div class="message p-3 d-none">
                            <p>Thank you for taking time to provide your feedback to the editors.</p>
                            <p>Your feedback is important to us. However, we do not guarantee individual replies due to the high volume of messages. </p>
                        </div>                        
                    </form>
                </div>
            </div>
        </div>
        
        <div class="modal fade modal-custom modal-custom-email d-print-none" tabindex="-1" role="dialog" id="feedback-email">
            <div class="modal-dialog" role="document">
                <div class="modal-content">
                    <div class="modal-header mb-4">
                        <h6 class="text-low-up text-uppercase text-center modal-custom-subtitle">E-mail the story</h6>
                        <h5 class="modal-title text-center with-hr">Raspberry Pi system can detect viruses on other devices without use of software</h5>
                        <button class="modal-custom__close" type="button" data-dismiss="modal" aria-label="Close">
                            <svg>
                                <use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_close" x="0" y="0"/>
                            </svg>
                        </button>
                    </div>
                    <div class="modal-body">
                        <form class="modal-custom-form" name="email" method="post" action="https://sciencex.com/api/story/email/561115672/" novalidate >
                            <div class="row">
                                <div class="col-md-6">
                                    <div class="form-group">
                                        <label for="modal-email-frend">Your friend's email</label>
                                        <input type="email" name="emailTo" class="form-control form-control-lg" id="modal-email-frend" value="" required>
                                    </div>
                                </div>
                                <div class="col-md-6">
                                    <div class="form-group">
                                        <label for="modal-email-self">Your email</label>
                                        <input type="email" name="emailFrom" class="form-control form-control-lg" id="modal-email-self" required>
                                    </div>
                                </div>
                            </div>
                            <div class="row">
                                <div class="col-12">
                                    <div class="form-group">
                                        <input type="checkbox" name="nwletter" value="1" id="modal-email-subscribe" class="modal-custom-form__checkbox">
                                        <label for="modal-email-subscribe">
                                            I would like to subscribe to Science X Newsletter. <a href="https://sciencex.com/help/newsletter/" class="text-info" target="_blank">Learn more</a>
                                        </label>
                                    </div>
                                </div>
                            </div>
                            <div class="row">
                                <div class="col-md-6">
                                    <div class="form-group">
                                        <label for="modal-email-name">Your name</label>
                                        <input type="text" name="name" class="form-control form-control-lg" id="modal-email-name">
                                    </div>
                                    <div class="modal-custom-email__notice mb-4 mb-md-0">
                                        <h6 class="text-low mb-2">Note</h6>
                                        <p class="text-low text-regular">
                                            Your email address is used <strong>only</strong> to let the recipient know who sent the email. Neither your address nor the recipient's address will be used for any other purpose. The information you enter will appear in your e-mail message and is not retained by Tech Xplore in any form. 
                                        </p>
                                    </div>
                                </div>
                                <div class="col-md-6">
                                    <div class="form-group">
                                        <label for="modal-email-message">Your message</label>
                                        <textarea name="comments" class="form-control no-resize" id="modal-email-message" rows="8"></textarea>
                                    </div>
                                </div>
                            </div>
                            <div class="row">
                                <div class="col-12">
                                    <small class="text-warning" id="email-error"></small>
                                </div>
                                <div class="col-auto mx-auto mt-4">
                                    <button type="submit" class="btn btn-warning text-low-up">Send</button>
                                </div>
                            </div>
                        </form>
                    </div>
                </div>
            </div>
        </div>
        
        <div class="modal fade modal-custom d-print-none" tabindex="-1" role="dialog" id="notify">
            <div class="modal-dialog" role="document">
              <div class="modal-content">
                 <div class="modal-header mb-4">
                    <button class="modal-custom__close" type="button" data-dismiss="modal" aria-label="Close">
                        <svg>
                            <use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_close" x="0" y="0"/>
                        </svg>
                    </button>
                </div>
                <div class="modal-body">
                    <div class="alert alert-info mb-4" role="alert">
                        <div class="col-9">
                         <p class="modal-message"></p>
                        </div>
                    </div>
                </div>
              </div>
            </div>
          </div>
        </div>
    </main>

        
        

        
            <footer class="footer py-5 d-print-none">
                <div class="container">
                    <div class="row mb-5 pb-3">
                        <div class="col-md-4 mb-4 mb-md-0">
                            <a href="https://phys.org/" class="footer-company">
                                <figure class="footer-figure">
                                    <img src="https://techx.b-cdn.net/tmpl/v2/img/Physorg.svg" alt="Phys.org logotype">
                                    <figcaption>
                                        <h3 class="text-low-up mb-2">Phys.org</h3>
                                        <p class="text-low mb-0">Daily science news on research developments and the latest scientific innovations</p>
                                    </figcaption>
                                </figure>
                            </a>
                        </div>
                        <div class="col-md-4 mb-4 mb-md-0">
                            <a href="https://medicalxpress.com/" class="footer-company">
                                <figure class="footer-figure">
                                    <img src="https://techx.b-cdn.net/tmpl/v2/img/MedicalXpress.svg" alt="MedicalXpress logotype">
                                    <figcaption>
                                        <h3 class="text-low-up mb-2">Medical Xpress</h3>
                                        <p class="text-low mb-0">Medical research advances and health news</p>
                                    </figcaption>
                                </figure>
                            </a>
                        </div>
                        <div class="col-md-4">
                            <a href="https://sciencex.com/" class="footer-company">
                                <figure class="footer-figure">
                                    <img src="https://techx.b-cdn.net/tmpl/v2/img/ScienceX.svg" alt="ScienceX logotype">
                                    <figcaption>
                                        <h3 class="text-low-up mb-2">Science&nbsp;X</h3>
                                        <p class="text-low mb-0"> The most comprehensive sci-tech news coverage on the web</p>
                                    </figcaption>
                                </figure>
                            </a>
                        </div>
                    </div>
                    <div class="row mb-5">
                        <div class="col-8 col-xl-5 offset-xl-1 mb-5 mb-md-0">
                            <h2 class="footer-title mb-3 mb-md-2">Newsletters</h2>
                            <form action="#" name="nwsubscribe" class="footer-form">
                                <div class="form-row align-items-start">
                                    <div class="col-7 mb-4">
                                        <input type="email" name="email" class="form-control form-control-lg" aria-describedby="emailHelp" placeholder="Email">
                                    </div>
                                    <div class="col-4">
                                        <input type="hidden" name="project" value="techx">
                                        <button type="submit" class="btn btn-block btn-warning border-bold">Subscribe</button>
                                    </div>
                                </div>
                                <div class="form-row">
                                    <div class="col mb-4">
                                        <span id="emailHelp" class="form-text text-low-up text-regular">
                                            Science X Daily and the Weekly Email Newsletter are free features that allow you to receive your favorite sci-tech news updates in your email inbox
                                        </span>
                                    </div>
                                </div>
                            </form>
                        </div>
                        <div class="col-md-6 col-xl-5">
                            <h2 class="footer-title mb-3 mb-md-2">Follow us</h2>
                            <ul class="follow">
                                <li class="follow-item">
                                    <a href="https://www.facebook.com/TechxploreCom" class="follow-link" target="_blank">
                                        <svg>
                                            <use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_fb" x="0" y="0"/>
                                        </svg>
                                    </a>
                                </li>
                                <li class="follow-item"><a href="https://twitter.com/techxplore_com" class="follow-link" target="_blank">
                                    <svg>
                                        <use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_twit" x="0" y="0"/>
                                    </svg>
                                </a></li>                    
                                <li class="follow-item"><a href="https://www.linkedin.com/company/tech-xplore/" class="follow-link" target="_blank">
                                    <svg>
                                        <use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_linkedin" x="0" y="0"/>
                                    </svg>
                                </a></li>
                                <li class="follow-item"><a href="https://techxplore.com/feeds/" class="follow-link">
                                    <svg>
                                        <use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_rss" x="0" y="0"/>
                                    </svg>
                                </a></li>
                            </ul>
                        </div>
                    </div>
                    <div class="row mb-5">
                        <div class="col-xl-10 offset-xl-1">
                            <nav class="nav footer-nav justify-content-between">
                                <ul class="nav flex-column">
                                    <li class="nav-item">
                                        <a class="nav-link" href="#" rel="top">Top</a>
                                    </li>
                                    <li class="nav-item">
                                        <a class="nav-link" href="https://techxplore.com/">Home</a>
                                    </li>
                                    <li class="nav-item">
                                        <a class="nav-link" href="https://techxplore.com/search/">Search</a>
                                    </li>
                                    <li class="nav-item">
                                        <a class="nav-link" href="https://techxplore.com/news/2022-01-raspberry-pi-viruses-devices-software.html?deviceType=mobile" rel="nofollow">Mobile version</a>
                                    </li>
                                </ul>
                                <ul class="nav flex-column">
                                    <li class="nav-item">
                                        <a class="nav-link" href="https://sciencex.com/help/" target="_blank" rel="nofollow">Help</a>
                                    </li>
                                    <li class="nav-item">
                                        <a class="nav-link" href="https://sciencex.com/help/contactus/" target="_blank" rel="nofollow">FAQ</a>
                                    </li>
                                    <li class="nav-item">
                                        <a class="nav-link" href="https://sciencex.com/help/about-us/" target="_blank" rel="nofollow">About</a>
                                    </li>
                                    <li class="nav-item">
                                        <a class="nav-link" href="https://sciencex.com/help/feedback/" target="_blank" rel="nofollow">Contact</a>
                                    </li>
                                </ul>
                                <ul class="nav flex-column">
                                    <li class="nav-item">
                                        <a class="nav-link" href="https://sciencex.com/profile/">Science X Account</a>
                                    </li>
                                    <li class="nav-item">
                                        <a class="nav-link" href="https://sciencex.com/help/donate/">Sponsored Account</a>
                                    </li>
                                    <li class="nav-item">
                                        <a class="nav-link" href="https://sciencex.com/help/newsletter/">Newsletter</a>
                                    </li>
                                    <li class="nav-item">
                                        <a class="nav-link" href="https://techxplore.com/archive/">Archive</a>
                                    </li>
                                </ul>
                                <ul class="nav flex-column">
                                    <li class="nav-item">
                                        <a class="nav-link" href="https://play.google.com/store/apps/details?id=com.PhysOrg.TechXplore">Android app</a>
                                    </li>
                                    <li class="nav-item">
                                        <a class="nav-link" href="https://itunes.apple.com/us/app/tech-xplore/id1154953172?mt=8">iOS app</a>
                                    </li>
                                    <li class="nav-item">
                                        <a class="nav-link" href="https://techxplore.com/feeds/">RSS feeds</a>
                                    </li>
                                    <li class="nav-item">
                                        <a class="nav-link" href="javascript:void(0)" data-action="webpush">Push notification</a>
                                    </li>
                                </ul>
                            </nav>
                        </div>
                    </div>
                    <div class="row">
                        <div class="col-12 text-center">
                            <small class="text-low-up text-regular">&copy; Tech Xplore 2014 - 2022 powered by <a class="text-white" href="https://sciencex.com/">Science X Network</a></small>
                        </div>
                        <div class="col-12 mt-3 text-center">
                            <a class="footer-document" href="https://sciencex.com/help/privacy/" target="_blank">Privacy policy</a>
                            <a class="footer-document" href="https://sciencex.com/help/terms/" target="_blank">Terms of use</a>
                        </div>
                    </div>
                </div>
            </footer>
            <div class="popup-cookies bg-primary" id="js-popup-cookies">
                <h4 class="text-extra-large mb-4">Your Privacy</h4>
                <p class="text-low-up text-regular">
                    This site uses cookies to assist with navigation, analyse your use of our services, collect data for ads personalisation and provide content from third parties.
                    By using our site, you acknowledge that you have read and understand our <a href="https://sciencex.com/help/privacy/" class="popup-cookies-more" target="_blank">Privacy Policy</a>
                    and <a href="https://sciencex.com/help/terms/" class="popup-cookies-more" target="_blank">Terms of Use</a>.
                </p>
                <div class="d-flex align-items-center mt-4 flex-wrap flex-sm-nowrap popup-cookies-controls">
                    <a href="#" class="btn btn-warning px-5 text-low-up" data-cookies-close>I'm OK with that</a>
                    <a href="https://sciencex.com/help/cookies/" class="popup-cookies-more ml-4 text-low-up" target="_blank">Cookie options</a>
                </div>
            </div>
            <div class="modal fade modal-custom d-print-none" tabindex="-1" role="dialog" id="subscribe">
                <div class="modal-dialog" role="document">
                <div class="modal-content">
                    <div class="modal-header mb-4">
                        <button class="modal-custom__close" type="button" data-dismiss="modal" aria-label="Close">
                            <svg>
                                <use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_close" x="0" y="0"/>
                            </svg>
                        </button>
                    </div>
                    <div class="modal-body">
                        <h4 class="footer-title mb-3">E-mail newsletter</h4>
                        <form class="row mb-4" name="nwsubscribe">
                            <div class="col-sm-8">
                                <div class="form-group">
                                    <input type="email" name="email" class="form-control form-control-lg" id="nw-email" placeholder="email" required>
                                </div>
                            </div>
                            <div class="col-sm-4">
                                <input type="hidden" name="project" value="techx">
                                <button type="submit" class="btn btn-block btn-warning text-low-up">Subscribe</button>
                            </div>
                        </form>
                        
                        <h4 class="footer-title mb-3">Follow us</h4>
                        <ul class="follow">
                            <li class="follow-item">
                                <a href="https://www.facebook.com/TechxploreCom" class="follow-link" target="_blank">
                                    <svg>
                                        <use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_fb" x="0" y="0"/>
                                    </svg>
                                </a>
                            </li>
                            <li class="follow-item"><a href="https://twitter.com/techxplore_com" class="follow-link" target="_blank">
                                <svg>
                                    <use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_twit" x="0" y="0"/>
                                </svg>
                            </a></li>                    
                            <li class="follow-item"><a href="https://www.linkedin.com/company/tech-xplore/" class="follow-link" target="_blank">
                                <svg>
                                    <use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_linkedin" x="0" y="0"/>
                                </svg>
                            </a></li>
                            <li class="follow-item"><a href="https://techxplore.com/feeds/" class="follow-link">
                                <svg>
                                    <use href="https://techx.b-cdn.net/tmpl/v2/img/svg/sprite.svg#icon_rss" x="0" y="0"/>
                                </svg>
                            </a></li>
                        </ul>                
                    </div>
                </div>
                </div>
            </div>
            </div>
            <template id="adblock">        
                <div class="alert py-2 bg-danger fade" role="alert">
                    <div class="container text-white">
                        <a href="https://sciencex.com/help/adblock/" class="link-white">
                            It appears that you are currently using <strong id="adblock-type">Ad Blocking software</strong>. What are the consequences?
                        </a>
                        <button type="button" data-dismiss="alert" aria-label="Close">
                        <span aria-hidden="true" class="text-white">&times;</span>
                        </button>
                    </div>
                </div>
            </template>
            <script src="https://techx.b-cdn.net/tmpl/v2/js/svgxuse.2467773076.js"></script>
            <script src="https://techx.b-cdn.net/tmpl/v2/js/libs.169765678.js"></script>
            <script src="https://techx.b-cdn.net/tmpl/v2/js/common.3377692561.js"></script>
            
<script src="https://techx.b-cdn.net/tmpl/v2/js/news.169765678.js"></script>
<script id="facebook-jssdk" async="" src="//connect.facebook.net/en_US/sdk.js"></script>
<script>
    window.fbAsyncInit = function() {
      FB.init({
        appId      : '412372938960445', // App ID
        channelUrl : 'https://techxplore.com/fb_channel.htm', // Channel File
        version    : 'v2.12',
        status     : true, // check login status
        cookie     : true, // enable cookies to allow the server to access the session
        xfbml      : true  // parse XFBML
      });
    };
</script>

        
    </body>
        
    
    
    <!-- Quantcast Tag -->
    <script type="text/javascript">
        var _qevents = _qevents || [];       
        (function() {
        var elem = document.createElement('script');
        elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
        elem.async = true;
        elem.type = "text/javascript";
        var scpt = document.getElementsByTagName('script')[0];
        scpt.parentNode.insertBefore(elem, scpt);
        })();
        
        _qevents.push([{
        qacct:"p-5dNhPAnM9r0yY"
        },{
        qacct:"p-522H9WlBHUNiI"
        }]);
    </script>
    <noscript>
    <div style="display:none;">
    <img src="//pixel.quantserve.com/pixel/p-5dNhPAnM9r0yY.gif" border="0" height="1" width="1" alt="Quantcast"/>
    </div>
    </noscript>
    <!-- End Quantcast tag -->
    
</html>
